Jump to content
chili023

Open Source Prüfstandssoftware auf Basis von Arduino Mega und LabVIEW

Recommended Posts

vor 11 Minuten schrieb chili023:

Gibst du die Übersetzung ein oder misst du die aus?

Hab beides versucht.  Funktioniert aber nur mit der zündung. Mit direkter Eingabe stoppt der Lauf unmittelbar na h dem Start  wieder

Diesen Beitrag teilen


Link zum Beitrag
vor 1 Minute schrieb Hoerlytom:

Hab beides versucht.  Funktioniert aber nur mit der zündung. Mit direkter Eingabe stoppt der Lauf unmittelbar na h dem Start  wieder

Ok also das macht ja schon mal keinen Sinn.

 

Wo sitzt du?

Diesen Beitrag teilen


Link zum Beitrag

Hallo Forum!

Ich habe nun von Chili mein Board erhalten und bin nun am testen.

Leider bekomme ich im LabView keine Drehzahl über das Zündsignal. Über die manuelle Eingabe der Untersetzung funktionieren Messungen zuverlässig.

 

Aus dem Grund habe ich schon verschiedene Zündzangen und eine Krokoklemme zum Abnehmen des Zündsignals verwendet und die gelbe Kontroll-LED an dem Board flackert dabei auch immer. Dann habe ich über den seriellen Monitor in der Adruino IDE geschaut. Dabei erhalte ich die folgende beispielhafte Ausgabe:

 

4628;51.74;0;60516;0.00
4629;51.74;0;60516;0.00
4630;51.74;0;60516;0.00
4631;51.74;0;60516;0.00

 

Die erste Spalte ist ja eine fortlaufende Nummer und die 2 sowie 4 Spalte gehören meines Erachtens zur Rolle. Eine Ausgabe zum Zündsignal fehlt meines Erachtens.

 

Am Sketch habe ich nichts geändert. Gilt es dort noch was zu ändern oder warum wird nichts angezeigt? Habt noch Ideen?

 

 

Viele Grüße

Bearbeitet von RenaeRacer

Diesen Beitrag teilen


Link zum Beitrag

4631; fortlaufende nummer

51.74; Frequenz der Telegramme (es kommen 51,74 Telegramme/Sekunde)

0; Zündsignal

60516; Frequenz der Rolle  (kommt mir arg viel vor)  Welchen drehgeber hast du montiert? der Arduino steigt normal bei ca. 18000 aus?

0.00 wäre die Abgastemperatur

 

keine Ahnung warum bei dir kein Zündsignal angezeigt wird,
wenn die Led flackert scheint die Schaltung ansich ja zu funktionieren...

evtl nur eine Lötstelle vergessen oder so?

Diesen Beitrag teilen


Link zum Beitrag
vor 49 Minuten schrieb Werner Amort:

60516; Frequenz der Rolle  (kommt mir arg viel vor)  Welchen drehgeber hast du montiert?

 

Hallo Werner!

 

Ich habe exakt den Drehgeber, den du auch verwendest.

Der macht erstaunlicherweise keine Probleme...

Im Anhang u. a. ein Bild einer Messung eines 60ccm Simson Mopeds nach händischer Eingabe der Gesamtuntersetzung.

 

Aber kann es sein, dass die hohe Frequenz des Drehgebers die Ausgabe des Zündsignals beeinflusst?

Welche Werte erreichst du?

0b4aca0532ae9097a5ab2e53ea872c51.jpg

1f596a8cd478f4bebe1383789ab37642.jpg

8ae007ac99f9341e77a67e3b154e1f8e.jpg

b63e680e2b8b758fa61dc6441972fe16.jpg

f26968d203f464eaee5a190f76fc2679.jpg

  • Like 1

Diesen Beitrag teilen


Link zum Beitrag

die Probleme die ich zum beispiel mit der Zündmessung hatte waren dass einfach dass sich der Arduino aufgehängt hat und keine Messung mehr möglich war...

hier hat dann der Aluhut geholfen

Diesen Beitrag teilen


Link zum Beitrag

Wie gesagt, da hängt sich nichts auf. Geht alles wunderbar soweit.

Wenn ich das Multimeter an das Krokokabel hänge, kommt ein Signal an. Schließe ich das Kabel an "IGN" am Board an, flackert auch die "IGN Pulse" Kontroll-LED am Board. Aber danach ist Schluss.:???:

Diesen Beitrag teilen


Link zum Beitrag

Ich hab ein Problemchen,

Es werden die Einstellungen in Labview nichtmehr gespeichtert?

Das heißt nach einem Reboot muss ich Filter und Rollenträgheit immer neu eingeben,
 

 

ähm wie funktioniert das?
speichert die EXE ihre Konfiguration in der Konfig.xml?
 

 

Diesen Beitrag teilen


Link zum Beitrag

Eigentlich sollte die gespeichert werden, wenn du das Programm über den Button beendest.

Wenn du im Labview über den Abbrechen-Button abschießt natürlich nicht.

 

Wenn die Konfig noch da ist, musst du das nur einmal sauber machen. Laden kannst du auch aus einem alten Lauf.

  • Like 1

Diesen Beitrag teilen


Link zum Beitrag

Fehler gefunden.

Ich hab den Programmordner in C:\\Programme\

öffne das Programm aber ohne Adminrechte, damit fehlten beim schließen die Berchtigungen.

1x geöffnet mit Adminrechte,
alles eingestellt,
geschlossen,
und die Einstellungen bleiben erhalten :-)

Ich lass das mal so jetzt als Sicherheit so dass niemand was vertaddelt...

Bearbeitet von Werner Amort

Diesen Beitrag teilen


Link zum Beitrag

ein kleines Detail was ich praktisch fände.

keine Ahnung ob Labview die Option hergäbe,
aber könnte man das nicht so machen dass beim Abspeichern als Dateinahme immer der vorherige vorgeschlagen wird mit fortlaufender Nummer hintendrann?


oder wie handhabt ihr das in der Praxis...

ich mach ja immer mindestens 3 Läufe pro Änderung,
momentan schaut ein Ordner ca so aus

Dl200-3g-hd100-1
Dl200-3g-hd100-2
Dl200-3g-hd100-3
Dl200-3g-hd98-4
Dl200-3g-hd98-5
Dl200-3g-hd98-6'
Dl200-3g-hd98-nadel-3clip-7
Dl200-3g-hd98-nadel-3clip-8

Dl200-3g-hd98-nadel-3clip-9

usw

das setup muss man fast in den dateinamen schreiben um im recalc dann direkt was zu finden?

Bearbeitet von Werner Amort

Diesen Beitrag teilen


Link zum Beitrag

Erstelle ein Benutzerkonto oder melde dich an, um zu kommentieren

Du musst ein Benutzerkonto haben, um einen Kommentar verfassen zu können

Benutzerkonto erstellen

Neues Benutzerkonto für unsere Community erstellen. Es ist einfach!

Neues Benutzerkonto erstellen

Anmelden

Du hast bereits ein Benutzerkonto? Melde dich hier an.

Jetzt anmelden

  • Wer ist Online   0 Benutzer

    Keine registrierten Benutzer online.



×

Wichtiger Hinweis

Wir haben einen Cookie auf deinem Endgerät abgespeichert, um dein Benutzererlebnis zu optimieren. Du kannst deine Cookie Einstellungen ändern, falls du dies nicht wünscht. Ansonsten gehen wir davon aus, dass es OK für dich ist.
Weiterhin ist auf dieser Webseite Google Analytics aktiviert. Hier kannst du für alle Webseiten verhindern, dass du durch Google Analytics erfasst wirst: http://tools.google.com/dlpage/gaoptout.
Mit der Nutzung des GSF erklärst du dich mit unseren Datenschutzerklärung und unseren Nutzungsbedingungen einverstanden.