Jump to content

Open Source Prüfstandssoftware auf Basis von Arduino Mega und LabVIEW


Recommended Posts

Genau.

Das kann ich dann einfach rein programmieren.

Gibt der auch 0-5V aus?

 

Hat deiner 12V? Wie bekommt der die? Ich möchte die Stromversorgung in das Board integrieren.

 

Der V4 von Knödler kann auch per rs232 Fehler ausgeben.

Wie funktioniert das beim 14point7?

 

Link to post
Share on other sites
  • Replies 1.8k
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Hallo liebe Gemeinde, ich möchte hier unser Projekt vorstellen. Seit nun mehr 2 Jahren tüftel ich an einer sauberen Lösung, Leistung an Rollenprüfständen zu messen und die Ergebnisse in eine Datenbank

Sonderbare Zeit momentan, die wie alle gerade erleben müssen, aber alles hat auch seine positiven Seiten - eine davon ist, dass man mehr Zeit zum Programmieren findet. Aktuell haben wir folgende Featu

Dateiname beim automatischen Speichern wird auf @Werner Amort's Anregung hin noch folgendermaßen angepasst, dass Maximalleistung und Drehzahl bei Maximalleistung in den Namen aufgenommen werden:

Posted Images

Genau.
Das kann ich dann einfach rein programmieren.
Gibt der auch 0-5V aus?
 
Hat deiner 12V? Wie bekommt der die? Ich möchte die Stromversorgung in das Board integrieren.
 
Der V4 von Knödler kann auch per rs232 Fehler ausgeben.
Wie funktioniert das beim 14point7?
 



Super [emoji41] Ja genau 0-5V ist das Signal !
Aber würde AFR bevorzugen. Ist ja eigentlich das selbe, finde Ich aber persönlich angenehmer !

Der Controller benötigt 12V, diese bekommt er bei Mir, von einer Batterie, wo auch die Prüfstand-Hardware aktuell dran hängt !
Nutze Ihn aktuell Stationär.

Funktioniert nicht, er hat ein Anschluss für eine LED woran man erkennt, ob die Heizung gerade läuft!




Gesendet von iPhone mit Tapatalk
Link to post
Share on other sites

Alles klar. Läuft. AFR oder Lambda kannst du dann in LabVIEW einstellen.

 

Ich will die Heizung zusammen mit dem Board über ein 12V 4A Netzteil betreiben.

Weniger Kabel. Ich hasse Kabel!

Aber Batterie geht auch.

 

Danke für die Info.

 

 

Link to post
Share on other sites

Mahlzeit, habe da mal ein Problem.

1. Mega angeschlossen/ Treiber installiert

2. Ring ICP auf Mega überprüft und aufgespielt !

3.Prüfstand exe gestartet

4. kurz gewartet und auf Start gedrückt.

Passiert aber gar nichts !?

Was mach Ich denn falsch ? Habe dann extra den Mega noch mit 9 V versorgt, aber keine Änderung.

Unten Steht auch immer Com6 obwohl der Mega auf Com5 ist. Bekomme Ich aber nicht geändert ! Bzw, bringt es nichts !

904d50f39fc82a5d16a026f494906267.jpg


Gesendet von iPhone mit Tapatalk

Link to post
Share on other sites

Ich wollte Ihn jetzt bloß zum testen zu Hause nutzen !

Dafür war ja irgendwie der Debug Modus oder nicht !?

Und wenn Ich ihn am Prüfstand ausprobieren will, welche Ino-Datei benötige Ich dann ?


Gesendet von iPhone mit Tapatalk

Link to post
Share on other sites
vor 3 Stunden schrieb Bosst:

Mahlzeit, habe da mal ein Problem.

1. Mega angeschlossen/ Treiber installiert

2. Ring ICP auf Mega überprüft und aufgespielt !

3.Prüfstand exe gestartet

4. kurz gewartet und auf Start gedrückt.

Passiert aber gar nichts !?

Was mach Ich denn falsch ? Habe dann extra den Mega noch mit 9 V versorgt, aber keine Änderung.

Unten Steht auch immer Com6 obwohl der Mega auf Com5 ist. Bekomme Ich aber nicht geändert ! Bzw, bringt es nichts !

904d50f39fc82a5d16a026f494906267.jpg


Gesendet von iPhone mit Tapatalk

 

Also ich hab LAPview 2014 mit 32 Bit an meinem 64 Bit Windows 7 Rechner installiert da der mit 64 Bit bei mir nicht funktionierte!

Dann hab ich den WildGruChil_V0.182 installiert und konnte so wie du auch den COM 6 nicht ändern aber mit dem visa520full hab ich die COM`s im WildGruChil Programm dann ändern können!

http://www.ni.com/download/ni-visa-5.2/3337/en/

 

  • Like 3
Link to post
Share on other sites
 
Also ich hab LAPview 2014 mit 32 Bit an meinem 64 Bit Windows 7 Rechner installiert da der mit 64 Bit bei mir nicht funktionierte!
Dann hab ich den WildGruChil_V0.182 installiert und konnte so wie du auch den COM 6 nicht ändern aber mit dem visa520full hab ich die COM`s im WildGruChil Programm dann ändern können!
http://www.ni.com/download/ni-visa-5.2/3337/en/
 




Danke Dir, jetzt klappt es !



Gesendet von iPhone mit Tapatalk
  • Like 1
Link to post
Share on other sites

@Motorhead

@Basti_MRP

@SMarco

@Malzi1977

Bosst hat sich um die Platinen gekümmert. Bei 20 Platinen kostet eine Platine (mit allen Bohrungen, Verzinnung ohne Bauteile) 8,085€ ohne MwSt.

 

Bei Interesse bitte melde.

 

 

Es scheint einen Lieferengpass für die HEF4093 zu geben. Oder hat jemand ne Bezugsquelle. Ich hab noch 29 Stück.

Bezugsquelle HEF:

http://bg-electronics.de/shop/product_info.php/products_id/157

Edited by chili023
Link to post
Share on other sites

Will mal ein kleines Update geben:

Die Software des Arduino mit BME280 und Thermoelementauswertung ist abgeschlossen.

Als nächstes kommt die Implementierung in Labview.

@grua und @BugHardcore arbeiten daran. Die zwei haben bereits in der Zwischenzeit einiges geleistet (Stabilität verbessert, Bedienung und Datenverarbeitung angepasst)

@wildstyler und ich haben die ersten beiden Boards mit BME280 und Thermoelementauswertung. Die werden jetzt am We getestet.

Jesco @praktikant kommt am WE bei mir vorbei damit wir das Programm mal ausgiebig testen können, mit einem potenten Roller. (Naja eigentlich will er nur seine Mopete testen.)

 

Wenn alles gut verläuft poste ich dann die Neue Software und den Arduino Code.

 

Beachtet bitte die Sammelbestellung, bei 8 € pro Platine kommt das gesamte Board (alle Teile nicht zusammengelötet) auf ca. 20 € ohne BME und Thermoelementeauswerter. Mit BME und Thermoelementeauswerter dann auf ca 50€.

  • Like 1
Link to post
Share on other sites

Ich habe das jetzt nicht mehr so perfekt verfolgt und habe von dem Elektronik-Schnick-Schnack auch eher nicht so den Plan.

 

Ich habe: Rolle mit einem 32 Zähne Zahnrad und einem 12V induktivsensor, läuft momentan über die Soundkarte mit GSF-Dyno.

Ich möchte: Ein "Ding" an das ich diesen Induktivsensor anschließe, auf der anderen Seite ist ein USB Kabel, das stecke ich in den PC. 

Dann installiere ich die Software und los gehts.

Ist das so oder muss ich den Lötkolben schwingen und einen Linux Großrechner mit 27 Prozessoren anschaffen? :-D

  • Like 1
Link to post
Share on other sites

Also Löten und einen Arduino anschaffen musst du schon noch.

 

Bei den Testversionen gab es noch Probleme mit einem Uraltrechner. Da lief das Programm zwar, aber irgendwo in der Kommunikation hakte es.

Wir sind aber schon deutlich stabiler und Anwenderfreundlicher als bei der verlinkten Version...

 

PS: Die Version da oben nutzt nur einen Kern :-D

Edited by BugHardcore
  • Like 1
Link to post
Share on other sites
vor 1 Stunde schrieb Basti_MRP:

Ich habe das jetzt nicht mehr so perfekt verfolgt und habe von dem Elektronik-Schnick-Schnack auch eher nicht so den Plan.

 

Ich habe: Rolle mit einem 32 Zähne Zahnrad und einem 12V induktivsensor, läuft momentan über die Soundkarte mit GSF-Dyno.

Ich möchte: Ein "Ding" an das ich diesen Induktivsensor anschließe, auf der anderen Seite ist ein USB Kabel, das stecke ich in den PC. 

Dann installiere ich die Software und los gehts.

Ist das so oder muss ich den Lötkolben schwingen und einen Linux Großrechner mit 27 Prozessoren anschaffen? :-D

Da es mehrere Anfragen gibt, würde ich eine fertige Platine mit allen drum und dran anbieten. Mit BME(Umgebungs Druck, Temp und Feuchte) und MAX (Thermoelementeauswerter) für 80 € ohne für 40€. Bevor ich aber die Verantwortung dafür übernehme, möchte ich den jetzigen Entwicklungsstand ausgiebig testen. Am Montag kann ich dann mehr dazu sagen.

 

Ich halte euch auf dem Laufenden

  • Like 3
Link to post
Share on other sites

ACHTUNG das Board ändert sich nochmal.

Ich habe gerade Hardware anstatt Software SPI mit dem MAX31855 (Thermoelementeauswerter) getestet. Damit ist eine wesendlich schneller Übertragung möglich. Eine schnelle Reaktion der Thermoelementeauswertung ist damit kein Problem (Thermoträgheit des Thermoelements natürlich ausgenommen, für Prüfstandläufe sollten 0.5 bis 1mm Thermoelemente benutzt werden).

Ich ändere das aktuelle Board ab und am Montag gebe ich 20 Platinen in Auftrag. Wenn die fertig sind werde ich die bestücken und verschicken.

 

Eagle Datei poste ich später.

 

 

Link to post
Share on other sites

Die Tests am WE sind bis auf die Tatsache das meine Rolle für Jescos Mopeten zu leicht ist erfolgreich verlaufen. Wir werden noch ein Paar Verbesserungen im Programmablauf vornehmen aber im Großen und ganzen sind die Tests gut verlaufen.

Das Board ist fertig und ich habe die 12V Platinen gerade in Auftrag gegeben. Wer es sich selbst ätzen möchte findet einen 5V und eine 12V eagle Datei im Beitrag 1.

 

Wenn die Platinen bei mir eingetroffen sind, werde ich sie bestücken und verschicken. Bis dahin, wird auch die neue Softwareversion zur Verfühgung stehen.

Lauf3.PNG

 

 

 

  • Like 2
Link to post
Share on other sites
vor 23 Stunden schrieb chili023:

Die Tests am WE sind bis auf die Tatsache das meine Rolle für Jescos Mopeten zu leicht ist erfolgreich verlaufen. Wir werden noch ein Paar Verbesserungen im Programmablauf vornehmen aber im Großen und ganzen sind die Tests gut verlaufen.

Das Board ist fertig und ich habe die 12V Platinen gerade in Auftrag gegeben. Wer es sich selbst ätzen möchte findet einen 5V und eine 12V eagle Datei im Beitrag 1.

 

Wenn die Platinen bei mir eingetroffen sind, werde ich sie bestücken und verschicken. Bis dahin, wird auch die neue Softwareversion zur Verfühgung stehen.

Lauf3.PNG

 

 

 

Warum ist hier das Zündsignal auf 4,04 eingestellt?

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    No registered users viewing this page.




×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.
By using the GSF you accept our Privacy Policy and our Guidelines.